PDA

View Full Version : Cannot determine perl version info from



ivan
06-13-2011, 02:57 AM
Please help me, I'm newbie mit Perl and Linux:

I cann't install perl modules in my Bluehost account, when I run this command
perl Makefile.PL PREFIX=$HOME/perl LIB=$HOME/perl

the result is:
Cannot determine perl version info from lib/Chart/Clicker.pm
Warning: prerequisite Color::Scheme 1.02 not found.
Warning: prerequisite DateTime::Set 0.27 not found.
Warning: prerequisite Geometry::Primitive 0.22 not found.
Warning: prerequisite Graphics::Color 0.27 not found.
Warning: prerequisite Graphics::Primitive 0.49 not found.
Warning: prerequisite Graphics::Primitive:river::Cairo 0.42 not found.
Warning: prerequisite Layout::Manager 0.31 not found.
Warning: prerequisite Math::Complex 1.56 not found. We have 1.35.
Warning: prerequisite Math::Gradient 0.04 not found.
Prototype mismatch: sub main:rompt: none vs ($;$) at /usr/lib/perl5/5.8.8/ExtUtils/MakeMaker.pm line 202
Warning: prerequisite Test:ifferences 0.47 not found.
Writing Makefile for Color::Scheme
Writing Makefile for Chart::Clicker

My "$HOME" environment variable is: HOME=/home3/mybioweb

I have searched in google for a solution but I don't still understand what means:
Cannot determine perl version info from lib/Chart/Clicker.pm

I must edit a installation file? Is an environment variable wrong?

Thanks for any answers and best regards,
Ivan.