Results 1 to 7 of 7

Thread: WP admin: White Screen of Death

  1. #1
    Join Date
    Feb 2010
    Posts
    1

    Unhappy WP admin: White Screen of Death

    I am getting the white screen of death on my WordPress install, but only on the admin side - not on the web facing site itself. That is running fine.

    When I go to the admin login, everything seems normal, but when I login, I'm returned a plain white page. "View source" on that page comes up blank. Admin WAS working at one point, but it stopped.

    I've done all of the troubleshooting things I can find out there on the web:
    - disabled plugins
    - disabled/changed themes
    - eliminated line breaks after closing php tags
    nothing I do seems to affect it.

    I came across a troubleshooting page that suggested temporarily adding "php_flag display_errors on" to my htaccess file for more verbose feedback, so I did that. It returned a "500 Internal Server Error" on the WordPress admin screen. (Only for a moment though, as the bluehost servers automatically commented that line out and suggested a php.ini file instead. I don't know php, so that is Greek to me.) That 500 internal server error is the first feedback I have gotten.

    I pulled up the server error log in Control Panel and see this:

    [Thu Feb 25 20:45:40 2010] [error] [client 69.89.31.219] PHP Warning: Module 'PDO' already loaded in Unknown on line 0
    [Thu Feb 25 20:45:40 2010] [error] [client 69.89.31.219] PHP Warning: Module 'pdo_mysql' already loaded in Unknown on line 0
    [Thu Feb 25 20:45:40 2010] [error] [client 69.89.31.219] PHP Warning: Module 'pdo_sqlite' already loaded in Unknown on line 0
    [Thu Feb 25 20:45:40 2010] [error] [client 69.89.31.219] PHP Warning: Module 'SQLite' already loaded in Unknown on line 0

    Could that have anything to do with it?

    At this point I am looking for any thoughts, guidance or assistance on the matter. I'm tapped out.

    Thanks,

    -Chris

  2. #2
    Join Date
    Feb 2007
    Posts
    161

    Default

    I'm not a WordPress expert -- I'm not evena WP user, but there are a few things you might check that aren't WP specific.

    First, I would ensure you are running the latest version of WP. Compare your version with the current version on their website (not what you see in the CP).

    It is possible that your app has been comprimised in some way. You'll need to investigate that by comparing app versions and if necessary, file differences.

    With respect to a 500 ISE, I would first check that you have set correct permissions on the file. Make any necessary changes to reflect a 755 CHMOD on the file in question. On a Unix/Linux server, if permissions are not properly set on .cgi or .pl files, the server will return a 500 error. So check your cgi and pl files for proper permissions and change them to 755.

    But I would first be sure to update the app to the most current version. Beforeso, however, make a backup of your database and save to your local drive. Backup any other files that may be necessary, such as server and sql config files on your web space and any other files WP deems appropriate as depicted within their update guide.

    If you are already running the latest version, check permissions on the files.

    If neither of these are your problem, and you haven't been hacked, someone with WP experience will surely be along to help you further.

  3. #3
    Join Date
    May 2008
    Posts
    9

    Default

    Chris, when did this issue start. Thurs. the 25th?

    This is the same issue I have throughout all shopping cart installations.
    The culperate is the new PHP5 version BlueHost installed.
    I've been trying to get answers from tech support, chating, voice line, and now trouble tickets. But no answer or help or fix so far.
    They don't have a clue...or are being very quiet about something!!!
    They just say, fix your own code.
    What?? My sites have been very robust over the years and all previous PHP updates have not been an issue. So why is this my fualt.

    I'd say that last PHP5 install is a bug.
    The only way I could get any pages to stop the white screen was to install the new PHP5 master PHP.INI file. But then all sorts of functions fail throughout my sites. At least I can get a "Temporarry Out of Service" announcement showing on my clients sites.

    Lets... get this figured out before we lose all our clients.

  4. #4
    Join Date
    May 2008
    Posts
    9

    Default

    Here is some info. I've used.
    I'm not sure if this fixes your issue.

    WSOD "White Screen Of Death"
    This happens because your host has switched off error reporting(for good reasons). So whenever their is a fatal error in your PHP script, and you have error reporting turned off you are presented with white screen of death.

    Change php.ini
    If you can have access to php.ini file then change the display error property to On.

    display_errors = On
    Also make sure that error reporting property is at least set to

    error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT

  5. #5
    Join Date
    Nov 2006
    Location
    Sydney, Australia
    Posts
    4,944

    Default

    Quote Originally Posted by mach9 View Post
    WSOD "White Screen Of Death"
    This happens because your host has switched off error reporting(for good reasons). So whenever their is a fatal error in your PHP script, and you have error reporting turned off you are presented with white screen of death.
    Which is exactly what you want for a live site so that people visiitiing your site cannot deliberately create crash conditions that will produce error messages that help them figure out how to break in.

    By all means turn on error reporting to figure out why your script isn't working but once you fix it you should turn error reporting back off.

  6. #6
    Join Date
    May 2008
    Posts
    9

    Default

    Quote Originally Posted by felgall View Post
    Which is exactly what you want for a live site so that people visiitiing your site cannot deliberately create crash conditions that will produce error messages that help them figure out how to break in.

    By all means turn on error reporting to figure out why your script isn't working but once you fix it you should turn error reporting back off.
    Good point, felgall...

    I also found that these errors seem redundant for my PHP code.

    [Thu Feb 25 20:45:40 2010] [error] [client 69.89.31.219] PHP Warning: Module 'PDO' already loaded in Unknown on line 0
    [Thu Feb 25 20:45:40 2010] [error] [client 69.89.31.219] PHP Warning: Module 'pdo_mysql' already loaded in Unknown on line 0
    [Thu Feb 25 20:45:40 2010] [error] [client 69.89.31.219] PHP Warning: Module 'pdo_sqlite' already loaded in Unknown on line 0
    [Thu Feb 25 20:45:40 2010] [error] [client 69.89.31.219] PHP Warning: Module 'SQLite' already loaded in Unknown on line 0

    Is stating that module is already loaded...
    I simply commented these statments out of the PHP.INI near the end of the file. Under the ZEND.
    No more errors showing. All seems to be working for me.
    Keep in mind... What I did may not work for you.

  7. #7

    Default

    For the php.ini, you may want to try renaming your current php.ini file and then using the PHP Config icon in the cPanel to re-install another php.ini file, but don't forget to rename it from php.ini.default to php.ini.

    Here are some possible causes and solutions for a White Screen of Death:

    Broken theme...
    In Database table wp_options Page 2 change the template and stylesheet entries. Type in: default . http://wordpress.shadowlantern.com/?p=54

    Incompatible Plugin Enabled...

    Disable all plugins (or rename the plugin folder), then add them back one at a time to see which one causes the problem.

    Cache Files corrupted...
    In wp_content rename all files that contain "cache" in the name. This should be done in conjunction with renaming the plugins folder.

    A partially complete upgrade...
    Re-upload all the core WordPress files for your current version of WordPress.

    FTP Client making a mess of the upgrade...
    Get another FTP client and re-upload the upgrade files.

    Simple Scripts did not complete the upgrade...
    Upgrade manually and install fresh upgrade files via FTP.

    Something failed running /wp-admin/upgrade.php upgrade script...

    Find out what failed (check logs), fix it and re-upgrade.(See above)

    Hopefully some of those will help someone get their WSOD issues fixed. As always, be SURE to get a backup before you upgrade, and before you start messing with your database. :)
    Last edited by bh_WP_fan; 03-03-2010 at 08:44 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •