Results 1 to 5 of 5

Thread: [an error occurred while processing this directive]

  1. #1

    Default [an error occurred while processing this directive]

    When I deployed a client's website (npmsnow.com), my PHP includes were non-functional. My initial response was to debug my code, however, I had already checked the same code on another host, as well as my testing server and the site was free of any complications in those environments. After adding a handler to parse my .html files as PHP, the following error displayed on page load: [an error occurred while processing this directive].

    Bluehost support has generally been non-responsive to my requests for help.

  2. #2

    Default

    Additional information:

    - The PHP code I've incorporated is: (1) a set of PHP includes for header and footer and (2) a PHP web form.
    - I have checked my links several times
    - I have tried changing my primary file extensions from .html to .php (and updating all the relevant links)
    - I have tried .htaccess changes
    - I have tried adding Apache handlers via cPanel

  3. #3

    Default

    Any help you can offer would be greatly appreciated. I have looked through many prior posts, following several suggestions found within. However, the issue persists.

  4. #4

    Default

    ISSUE RESOLVED: For the benefit of anyone encountering a similar problem, try the steps that follow:

    - Go to cPanel
    - Open File Manager from Files section
    - Navigate to domain folder
    - Check "Perms" column on far right hand side
    - Files should be set to: 0644 (this is the UNIX file permissions)
    - Folders should be set to: 0755

    This will change your file permissions to their proper settings for the Bluehost file system. Additionally, if you have PHP code within.htm or .html files, you will need to add an additional Apache handler to tell Bluehost to parse these files as PHP. Do this using Apache Handlers in cPanel:

    HANDLER: application/x-httpd-php5s
    EXTENSIONS: .php .htm .html

  5. #5

    Default

    Thank you very much for posting this! I encountered the same error, saw this post and I followed your instructions...it worked! BIG HELP! thanks a lot!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •